В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Zaya191
Zaya191
05.04.2023 10:41 •  Информатика

Составить программу вычисления арифметической прогрессии числовой последовательности. где кол-во элементов и сами элементы вводятся с клавиатуры?

Ответ:
знатокслава
знатокслава
27.05.2020 09:56

var
i,p,k,r,s:integer;
mas: array[1..100] of integer;
begin
s:=0;
read(k);
for i:=1 to k do
read(mas[i]);

r:=mas[2]-mas[1];

for i:=1 to k do
s:=s+mas[i];

writeln('raznost progressii=', r, ', summa elementov progressii=', s);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?