В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zontikmily
zontikmily
24.09.2020 23:13 •  Информатика

Написать программу вычисления значений функции: y=2x/(x+1) для всех х из интервала [-2; 2] с шагом равным 1 со схемкой и самой программой.

Ответ:
JoraUai0
JoraUai0
30.08.2020 17:00
Программа:
var x,y,h:real; 
begin
x:=-2;h:=1;
writeln(' x     y');
while x<=2 do
 begin
 write(x:3);
 if x+1<>0 then
   begin
    y:=2*x/(x+1);
   writeln(y:7:2)
  end
   else writeln('  функция не определена');
 x:=x+h;
 end;
end.

Пример:
 x     y
 -2   4.00
 -1  функция не определена
  0   0.00
  1   1.00
  2   1.33

Блок-схема - в прилагаемом файле
Написать программу вычисления значений функции: y=2x/(x+1) для всех х из интервала [-2; 2] с шагом р
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?