В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Хряшка
Хряшка
12.11.2021 09:42 •  Информатика

(паскаль авс) напишите программу которая в последовательности натуральных чисел определяет максимальное четное число. программа получает на вход количество чисел в последовательности, а затем сами числа. программа должна вывести одно максимальное четное число!

Ответ:
732tatyana732tatyana
732tatyana732tatyana
03.10.2020 02:51
Var a:array [0..1010] of longint;
n,max,i:longint;
begin
read (n);
for i:=1 to n do
read (a[i]);
max:=a[1];
for i:=2 to n do
if ((max<a[i]) and (a[i] mod 2=0)) then max:=a[i];
write (max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?