В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yakun3008
yakun3008
07.03.2023 17:28 •  Информатика

Составьте программу выводящую на экран таблицу умножения (от 1 до 10) на введённое вещественное число. например, ввели число 2.6 на экране: 2.6*1=2.6 2.6*2=5.2

Ответ:
Floki23
Floki23
18.09.2020 22:06
Program CrazyCoder;
var n:real; i:integer;
begin  write('Введите n ');
read(n); 
if (n<2) or (n>10) then    
     begin    
     while (n<=1) or (n>10) do    
          begin     
         writeln('Ошибка! Число n должно быть в диапазоне от 2 до 10');                   
         write('Введите n ');     
         read(n);     
         end;   
     end; 
   for i:=1 to 10 do 
   writeln(n,'*',i,'=',n*i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?