В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
nastya2735
nastya2735
10.12.2020 00:52 •  Информатика

Написать программу, выделяющую из некоторого заданного множества подмножество четных чисел. паскаль, как можно быстрее, .

Ответ:
Мегамозг0511
Мегамозг0511
03.10.2020 02:42
Var a,b:set of integer;
    i,n: integer;
begin
  write('кол-во элементов множества:  ');
  readln(n);
  randomize;
  for i:=1 to n do
  a:=a+[random(250)];
  write('элементы множества:  ');
  foreach i in a do
  begin
    write(i,' ');
    if i mod 2 = 0 then b:=b+[i];
  end;
  writeln;
  write('подмножество четных элементов:  ');
  foreach i in b do write(i,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?