Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
timati06blacstar
25.06.2020 13:43 •
Информатика
Найдите все элементы линейного массива целых чисел, которые больше среднего арифметического элементов массовов. в паскаль.
Ответ:
Angelona19
03.10.2020 02:36
Var ar:array[1..5] of integer;
i:integer;
s:real;
begin;
for i:=1 to 5 do
begin;
readln(ar[i]);
s:=s+ar[i];
end;
s:=s/5;
writeln('Среднее арифметическое:',s);
writeln('Result:');
for i:=1 to 5 do
if ar[i]>s then write(ar[i]:4);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
arisazenina783
25.05.2020 01:29
Вскобках система исчисления сравните числа: а) 95(10) и (2); б) aa(16) и 252(8); в) 100011(2) и 45(8)...
rushsh1
06.02.2020 14:16
Для хранения текста в восьми бытовой кодировке требуется 10 кбайт. автоматическое устройство осуществила перекодировку информационного сообщения в 16 бытовой код...
Алёнка7913
21.01.2021 04:36
Ккакому типу данных относятся перечисленные данные: 8.35; 100; 982.0; f; false...
nastya2737
09.08.2021 18:54
пмоготи решить по информатике на паскале. в кругу стоят n-ое количество , которые считаются считалочкой. каждый 3 человек выбывает. кто отсался. пример водиться:...
fanaidap
21.02.2021 02:17
Выделите красным цветом ложные высказывания....
MariSar
07.06.2023 23:44
Pascal дано натуральне число n. a) скільки цифр в числі n? b) скільки парних цифр в числі n...
sofiyakasheeva
12.04.2021 23:30
Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел кратных 5. программа получает на вход количество натуральных...
Svet1k03
15.08.2021 06:41
Укажите лишние а)изменение начертания б)выравнивание в)вставка г)изменение цвета...
angel66613666
15.09.2020 04:16
Наберите 1 литр воды в любом из сосудов. размер одного из сосудов (неизвестно какого) - 2 литра, размер второго - 11 литров. используйте цикл «n раз»....
Света1011111
15.09.2020 04:16
Для чего нужна маршрутизация в сети?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i:integer;
s:real;
begin;
for i:=1 to 5 do
begin;
readln(ar[i]);
s:=s+ar[i];
end;
s:=s/5;
writeln('Среднее арифметическое:',s);
writeln('Result:');
for i:=1 to 5 do
if ar[i]>s then write(ar[i]:4);
end.