В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
denis20043601
denis20043601
02.04.2020 08:27 •  Информатика

Решите , используя язык программирования паскаль: напишите программу вычисления стоимости покупки, состоящей из нескольких карандашей, линеек и тетрадей. их количество и цену задать вводом. ответ вывести в виде: сумма к оплате: … руб … коп.

Ответ:
Evlampy3
Evlampy3
03.10.2020 02:35
Var
k,kc,ks, r,rc,rs, l,lc,ls: Integer;
Summa: Integer;
begin
WriteLn('Введите цену карандаша'); ReadLn(kc);
WriteLn('Введите цену ручки'); ReadLn(rc);
WriteLn('Введите цену линейки'); ReadLn(lc);

WriteLn('Введите кол-во карандашей'); ReadLn(k);
WriteLn('Введите кол-во ручек'); ReadLn(r);
WriteLn('Введите кол-во линеек'); ReadLn(l);

ks:= k * kc; // цена карандашей
rs:= r * rc; // цена ручек
ls:= l * lc; // цена линеек
Summa:= ks + rs +ls; // общая цена всех 3-х
WriteLn('Сумма = ', Summa;
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?