В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
chorna202
chorna202
15.10.2020 23:57 •  Информатика

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.

Ответ:
VeshkinRuslan
VeshkinRuslan
03.10.2020 02:27
Var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
 begin
 if a[i]='1' then b:=b+st;
 st:=2*st;
 end;
writeln(b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?