В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alexandra171717
alexandra171717
24.04.2023 03:07 •  Информатика

Составить программу в pascal! задана последовательность слов. определить частоту вхождения каждого из слов в последовательность.

Ответ:
ppp13
ppp13
03.10.2020 02:27
Var   s,r,k: string;
         j: integer;
begin
  write('строка:  ');  readln(s);
    foreach k in s.Split(' ').Distinct do
    begin
      j:=0;
      foreach r in s.Split(' ') do
      if r=k then j:=j+1;
      writeln('слово   ','"',k,'"','   встречается ',j,' раз');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?