В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Катя18471
Катя18471
24.05.2020 04:00 •  Информатика

Написать программу, которая вводит десять чисел в одномерный массив, а затем определяет среднее арифмитичне элементов с четными индексами и нечетными индексами

Ответ:
лолодоидтд
лолодоидтд
03.10.2020 02:21
Var r,n,m,max,k,el,Sumh,Sumnh:integer;C:Array[0..9]of integer;Sh,Snh:real; 
Begin
for r:=0 to 9 do begin
C[r]:= random(50)-25;  write(C[r]:4);
if r mod 2 = 0 then Sumh := Sumh + C[r]
else Sumnh:= Sumnh + C[r];end;
Sh:= Sumh/5;Snh:= Sumnh/5;writeln;
writeln('среднеарифметическое элемент с четными индексами ',Sh:6:4);
write('среднеарифметическое элемент с четными индексами ',Snh:6:4);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?