Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
azizplay07
13.10.2022 11:16 •
Информатика
Требуется написать программу для перевода целых чисел из восьмеричной системы счисления в десятичную.
Ответ:
linaserdyuk13
03.10.2020 01:59
Var o,d,k,l: integer;
begin
read(o);
d := 0;
k := 1;
l := 1;
while l <= o do
begin
d := d + k*(o div l mod 10);
l := l * 10;
k := k * 8
end;
writeln(d)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
лолпрапти
26.09.2020 22:19
Дано число 243871. переведите число 243 в минимальную систему перевести,а 871 в двоичную подробно расписав....
Пени67
06.02.2020 07:10
Запишите числа в обратном и доп коде (в формате 1 байт(8разрядов)) -15¹⁰ -128¹⁰...
vanyaevsik
25.04.2023 18:46
нужно написать сочинение на тему: «Основы этикета» кратко...
мурgsng
20.12.2022 13:16
Какое количество информации в мегабайтах можно передать при пропускной канала в 1 Мбит\с...
сева167
30.05.2021 21:33
Примеры элементный состав обьекта! ?...
Пень01
30.01.2021 21:14
Понимающие информатику, кто что сможет, , , трачу на это 15 пунктов, ! 1. измерить в байтах объём текстовой информации в книге из 528 страниц, если на одной странице размещается...
tsts84
30.01.2021 21:14
Составьте программы для решения 1. найти площадь треугольника по двум сторонам и углу между ними. величину угла вводить в градусах. ответ дать с точностью до трёх знаков...
Kimberliny
30.04.2022 08:26
Соотнесите фрагмент поэмы А. С. Пушкина «Руслан и Людмила» и пропущенное в нём имя персонажа. ответы занесите в нижнюю таблицу. Фрагмент поэмы Имя персонажа1В толпе могучих...
nekit120
31.01.2023 00:54
Які на вашу думку зображені фантазії...
LEZIHINALINA
22.10.2022 23:28
Реши систему уравнений: {2x−y=18x−2,5y=3 {x= y= за...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
read(o);
d := 0;
k := 1;
l := 1;
while l <= o do
begin
d := d + k*(o div l mod 10);
l := l * 10;
k := k * 8
end;
writeln(d)
end.