В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу которая заполняет массив s [1..15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами

Ответ:
adamadam
adamadam
18.09.2020 15:56
Если в паскале то вот
vara:array [1..30] of integer;i,s,k,n:integer;h:real;begins:=0;k:=0;writeln('введите количество чисел');read(n);randomize;for i:=1 to n do begina[i]:=random(100);write(a[i]:3);end;writeln();for i:=1 to n do beginif (a[i] mod 2=0) and (i mod 2=0) then begins:=s+a[i];k:=k+1;end;end;if k>1 then h:=s/k;writeln(h); if k=0 then begin writeln('таких чисел нет'); read; halt; end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?