В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
violetta1888
violetta1888
23.05.2020 14:47 •  Информатика

3. напишите программу, которая подсчитывает, сколько чисел из последовательности делятся на 3 и при этом заканчиваются на 4. на выход программа получает сначала количество чисел в последовательности, а затем сами числа по одному. количество чисел не превышает 1000. введённые числа не превышают 30000. программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4. входные данные/выходные данные 8/4 12/ 14/ 24/ 54/ 44/ 33/ 84/ 114/

Ответ:
Nerror
Nerror
13.08.2020 15:20
Var
 a:array[1..1000]of integer;
 i,n,k,c,q:integer;
   begin
    readln(n);
    for i:=1 to n do
     begin
     readln(a[i]);
      if (a[i] mod 10 = 4) then
      begin
       k:=a[i];
       c:=0;
       while k>0 do
        begin
        c:=c + k mod 10;
        k:= k div 10;
        end;
        if c mod 3 = 0 then
        q:=q+1;
        end;
       end;
      writeln(q);
      end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?