В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Lool199865
Lool199865
19.10.2022 23:09 •  Информатика

Написать программу на языке паскаль: на место положительных элементов массива (a1, ) записать единицы и сосчитать их количество. для отрицательных элементов массива определить их сумму. исходные данные: n=12 a= [-8, 10, 11, -30, 21, 22, -5, 10, -10, -12, 1, 5]

Ответ:
Program mas1;
var a:array[1..100] of integer;
k,sum,n,i:integer;
Begin randomize;
k:=0;
sum:=0;
writeln('Введите размерность массива',n); 
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
begin if a[i]>0 then
begin a[i]:=1;
k:=k+1;
end;
write(' ',a[i]);
if a[i]<0 then
begin sum:=sum+a[i];
end;
end;
writeln(' sum=',sum,' k=',k);
readln;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?