В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лис8889
лис8889
09.08.2021 07:32 •  Информатика

Вести n чисел и найти среднее арифметическое. написать программу и нарисовать блок схему.

Ответ:
dwinchester15
dwinchester15
18.09.2020 13:58
#include <iostream>
using namespace std;
 int main(){
setlocale(LC_ALL,"Rus");
int N,dp,S,F,d;
S=0;F=0;d=0;
while(S<1){
cout<<"Выберите действие"<<endl;
cout<<"1.Ввод чисел"<<endl;
cout<<"2.Подсчет среднего арифметического"<<endl;
cout<<"Выполнить действие-";
cin>>dp;
switch(dp){
case 1:
cout<<"Введите число ";
cin>>N;
F=F+N;
d++;
break;
 case 2:
S=(float)F/d;
break;
}
}
cout<<"Среднее арифметическое="<<S<<endl; system("pause"); 
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?