В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sevasik12
sevasik12
16.10.2020 17:01 •  Информатика

Почему не работает запись в паскале по : написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе. вот запись, исправьте : program chisla; var a,b,k: integer; begin k: =0; writeln('введите число'); readln(a); repeat if(a mod 2=0)and(a mod 4=0)then k: =k+1 until a=0; writeln('количество чисел=',k) end.

Ответ:
danillirka
danillirka
18.09.2020 12:22
Var a,b,k:integer;
begin
k:=0;
writeln('Введите число');
readln(a);
repeat
if (a mod 10) in [4,8] then k:=k+1;
a:=a div 10;
until a=0;
writeln('Количество чисел=',k)
end.

Введите число
24583
Количество чисел=2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?