В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yisupova54
yisupova54
09.06.2023 14:23 •  Информатика

Написать программу. ввести последовательность чисел размерностью n. в этой последовательности: найти минимальный и максимальный элементы. среднее арифметическое отрицательных чисел вывести на экран значения min и max элементов и их номера, и среднее арифметическое

Ответ:
jru77
jru77
18.09.2020 10:20
// PascalABC.NET 3.0, сборка 1088
var
  n,i,max,min,s,t,k:integer;
begin
  Write('Введите количество членов последовательности: ');
  Read(n);
  Writeln('Вводите числа через пробел');
  max:=-32768; min:=32767; s:=0; k:=0;
  for i:=1 to n do begin
    Read(t);
    if t<min then min:=t
    else
      if t>max then max:=t;
    if t<0 then begin s:=s+t; Inc(k) end
    end;
  Writeln('Min=',min,', max=',max,', ср.арифм.=',s/k:0:5)
end.

Тестовое решение:
Введите количество членов последовательности: 7
Вводите числа через пробел
25 -6 39 -118 271 24 -15
Min=-118, max=271, ср.арифм.=-46.33333
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?