Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
danik2012daniweufyv3
09.09.2021 01:10 •
Информатика
Написать программу в с++ . надо. в произвольном тексте программа выводит самое короткое слово.
Ответ:
kirillshe2012
18.09.2020 08:48
//самое короткое слово
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int main(int argc, char** argv) {
int i=0,j=0,l=0;
char st[200];
char ch=' ';
cout<<" string: "; gets(st); cout<<endl;
string mins;
int mn,bgmn,emn,tek;
mn=strlen(st); bgmn=0;
while (true) {
while ((st[j]!=ch) and (j<strlen(st))) j++;
tek=j-l;
for (int i=l; i<j; i++)
{ if (tek<mn) { mn=tek; bgmn=l; emn=j-1; } }
if (j==strlen(st)) break;
j++; l=j;
}
//запись строки
for (int i=bgmn; i<=emn; i++) mins=mins+st[i];
cout<<"short word: "<<mins<<endl<<endl;
system("pause");
return(0);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
DarinaKachilova0910
08.12.2021 08:47
Как трамвай переводится на язык в книге информатика...
Mashylka999
08.12.2021 08:47
1. дополни предложения, в окошки напиши (скопируй) недостающие слова: (шрифт, алфавитном порядке, специальные окошки, кнопки изменения стиля, pt, дюйма, названия шрифтов, кнопки...
akhtyamovedgar
21.05.2023 02:05
Составить алгоритм поиска наименьшего из трех чисел А, В и С...
artems242
21.05.2023 02:05
Создайте приложение по вычислению квадратного корня, корня третьей , четвёртой, шестой степени заданного числа, в зависимости от установленных флажков...
lolol6y
19.03.2020 08:27
Хелп ми Нужно на питоне Известен алгоритм шифрования. В пароле не может быть цифр. Сначала пароль переписывают в обратном порядке. Потом все буквы сдвигаются в unciode вперед на...
Мираж005
23.06.2021 14:03
Найдите ошибку в задаче и исправьте. В ответе выписать исправный код. Найти сумму элементов одномерного массива. Размер произвольный. Элементы вводятся с клавиатуры. Program summa;...
avorob
13.02.2023 05:32
Предложение со словом не долюбливать...
kami179
13.02.2023 05:32
Пользователь работал с каталогом архив. сначала он поднялся на один уровень вверх, затем перешел в какой-то подкаталог текущего каталога и еще раз перешел в какой-то подкаталог текущего...
Deyzer777
13.02.2023 05:32
Почему стих пушкина названо соловей и роза а у кольцова только соловей ?...
alexperovo2006p00qrr
13.02.2023 05:32
Нужно написать письмо другу про музыку на .. 120-140 слов желательно с переводом.заранее...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
#include <cstdlib>
#include <cstring>
using namespace std;
int main(int argc, char** argv) {
int i=0,j=0,l=0;
char st[200];
char ch=' ';
cout<<" string: "; gets(st); cout<<endl;
string mins;
int mn,bgmn,emn,tek;
mn=strlen(st); bgmn=0;
while (true) {
while ((st[j]!=ch) and (j<strlen(st))) j++;
tek=j-l;
for (int i=l; i<j; i++)
{ if (tek<mn) { mn=tek; bgmn=l; emn=j-1; } }
if (j==strlen(st)) break;
j++; l=j;
}
//запись строки
for (int i=bgmn; i<=emn; i++) mins=mins+st[i];
cout<<"short word: "<<mins<<endl<<endl;
system("pause");
return(0);
}