В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dodoso
Dodoso
09.07.2020 21:37 •  Информатика

40 написать программу вычисления с результатом: y=ctg(x3+0.5) x€[0; 1] h=0.1

Ответ:
henrycarbone
henrycarbone
03.10.2020 01:39
// PascalABC.NET 3.0, сборка 1088
var
  x,y,t:real;
  i:integer;
begin
  for i:=0 to 10 do begin
    x:=i/10;
    t:=x*sqr(x)+0.5;
    y:=cos(t)/sin(t);
    Writeln('x=',x:3:1,', y=',y)
    end
end.

Тестовое решение:
x=0.0, y=1.83048772171245
x=0.1, y=1.82614498429306
x=0.2, y=1.79618385002611
x=0.3, y=1.71852553644354
x=0.4, y=1.58093809305141
x=0.5, y=1.38603127549996
x=0.6, y=1.1494046625412
x=0.7, y=0.890956788596857
x=0.8, y=0.625274002791611
x=0.9, y=0.355759266063965
x=1.0, y=0.0709148443026524
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?