В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Дмитрий1425
Дмитрий1425
07.10.2020 10:27 •  Информатика

Написать программу заполнить массив из 15 элементов случайными числами (-50; 50)посчитать сумму всех элементов массива посчитать количество отрицательных элементов.

Ответ:
tikmehr
tikmehr
15.09.2020 13:26
Если нужно на Паскале:

program test;
var mas : array[1..15] of integer;
sum : integer;
otr : integer;
i: integer;

begin
sum := 0;
otr := 0;
randomize;
for i:=1 to 15 do
begin
    mas[i] = -50 + random(100);
    sum := sum + mas[i];
    if mas[i] < 0
        then otr := otr + 1;
end;
writeln ('Сумма: ' + sum);
writeln ('Количество отрицательных элементов: ' + otr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?