В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
катя134689
катя134689
02.05.2021 01:42 •  Информатика

Всем . вообщем, вот и к ней необходимо написать программу(pascal). код программы будет ниже.нужно проверить его на ошибки и дать коментарии к коду. если код неправильный подкорректировать. буду признателен. заранее . : дана последовательность из n действительных чисел (n < = 100). написать программу для подсчета суммы этих чисел. код программы: var massiv: array [1..100] of real; sum: real; n,i: integer; begin clrscr; writeln ('введите количество чисел'); readln (n); for i: =1 to n do begin writeln ('введите ',i,'-ое число'); readln (massiv [i]); end; sum: =0; for i: =1 to n do sum: = sum + massiv [i]; writeln ('сумма последовательности равна ', sum: 0: 4); readln; end.

Ответ:
AltoДима
AltoДима
13.08.2020 14:56
Var i,n:integer;
k,k1:real;
begin;
readln(n);
for i:=1 to n do //повторить n раз
begin;             //начало тела цикла
  readln(k1);    //читаем промежуточную переменную
  k:=k+k1;      //прибавляем к общей сумме
end;               //конец тела цикла
writeln('Result:',k);   //вывод общей суммы
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?