В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RaritetnuWioN
RaritetnuWioN
07.05.2023 07:55 •  Информатика

Задать массив и решить var k, m: integer; dat: array[1..11] of integer; begin dat[1] : = 20; dat[2] : = 25; dat[3] : = 19; dat[4] : = 25; dat[5] : = 26; dat[6] : = 22; dat[7] : = 24; dat[8] : = 28; dat[9] : = 26; dat[10] : = 21; dat[11] : = 27; m : = 0; for k : = 1 to 11 do if dat[k] > 22 then begin m : = m + 1 end; writeln(m) end.

Ответ:
НемфодораТ
НемфодораТ
31.07.2020 11:57
// PascalABC.NET 3.0, сборка 1088
const
  Dat:array[1..11] of integer=(20,25,19,25,26,22,24,28,26,21,27);
var
  k,m:integer;
begin
  m:=0;
  for k:=1 to 11 do
  if Dat[k]>22 then Inc(m);
  Writeln(m)
end.

Тестовое решение:
7

А вот так можно написать программу, если знать немного больше, чем дают в школе:

// PascalABC.NET 3.0, сборка 1088
begin
  var Dat:array[1..11] of integer:=(20,25,19,25,26,22,24,28,26,21,27);
  Writeln(Dat.Where(x->x>22).Count)
end.

Но ведь в школе не ищут простых решений! (((
0,0(0 оценок)
Ответ:
eduardpiterskiy
eduardpiterskiy
31.07.2020 11:57
Var k, m: integer;Dat: array[1..11] of integer;
Beginfor k := 1 to 11 do begin
Dat[k]:= random(20)+10;
write(Dat[k]:4);
if Dat[k] > 22 then m := m + 1;
end;
writeln;writeln(m);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?