В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0502abylai
0502abylai
16.12.2021 21:45 •  Информатика

Кто -святой. составить программу, которая заполняет 11 элементов одномерного массива случайным образом, вычисляет их сумму, определяет min элемент в массиве

Ответ:
proadidas90
proadidas90
03.10.2020 01:27
Var x : array[1..11] of integer;
   n,s,i,min : integer;
begin
Randomize;
n:=11;
writeln('Сгенерированный массив:');
for i:=1 to n do
 begin
  x[i]:=random(21)-10;
  write(x[i],' ');
end;
writeln;
 s:=0;
min:=x[1];
for i:=1 to n do
 begin
 if x[i]<min then min:=x[i];
 s:=s+x[i]
 end;
writeln('s = ',s:5,'   min=',min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?