В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
schaposchnyk
schaposchnyk
25.07.2020 04:57 •  Информатика

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов. программа: pascal abc.

Ответ:
скмниниручвк
скмниниручвк
17.09.2020 23:27
Const
  n = 25;
var
  a: array[1..n] of integer;
  i, s: integer;
begin
  Writeln('Введите элементы массива');
  s := 0;
  for i := 1 to n do
  begin Read(a[i]); s := s + a[i] end;
  Writeln('Среднее значение элементов массива равно ', s/n)
end.
0,0(0 оценок)
Ответ:
Tavus1980
Tavus1980
17.09.2020 23:27
Var A:array[1..25] of Integer;
i:integer;
S:real;
begin
Readln(N);
For i:=1 to 25 do
Readln(A[i]);
For i:=1 to 25 do
S:=S+A[i];
S:=S/25;
Writeln(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?