Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
barbarask1
28.04.2021 11:12 •
Информатика
Написать программу на языке паскаль дано: а,b,с найти: s s=sqrt(p(p-a)(p-b)(p-c)) где р=(а+b+c)/2
Ответ:
Nastena102002
06.08.2020 23:20
Var a,b,c,s:real;
procedure Pl(var a,b,c,s:real);
var p:real;
begin;
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(s);
end;
begin;
readln(a);
readln(b);
readln(c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then
begin;
writeln('error');
exit;
end;
Pl(a,b,c,s);
end.
0,0
(0 оценок)
Ответ:
1LOSI1
06.08.2020 23:20
Var a,b,c,s:integer;
function f(a1,b1,c1:real):real;
var p:real;
begin
p:=(a+b+c)/2;
f:=sqrt(p*(p-a)*(p-b)*(b-c)); end;
BEGIN
readln(a,b,c);
writeln('S=',f(a,b,c):4:2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
anisa2004god
29.05.2020 07:51
Можно фаст решить даю хороший ответ Что будет выведено на экран в результате выполнения фрагмента алгоритма: X1:=3; X2:=5; readln(X1); writeln(X1+X2); Если при работе фрагмента...
asadbekakramov
02.02.2020 19:11
Разгадать шифр 11010100.00011010.11101101.11010100 D903...
ElliDiHastua
03.12.2020 18:50
Между населенными пунктами A,B,C,D,E Построены дороги протяжность которых (В километрах ) Определите длинну кратчайшего пути между пунктами A и E передвигаться можно только по...
Кириииил
06.11.2022 04:43
Какие изменения нужно внести в программу из примера 17 .1 для того, чтобы рисунок выглядел следующим образом. ! uses graphabc; var x, y, r: integer; begin r : = 10; x : = 10; y...
dina79kzkz
16.10.2020 18:53
чертёжнику был дан для исполнения следующий алгоритм: повтори 8 раз сместиться на (1, 3) сместиться на (-2, -5) конец сместиться на (40, 18) какую команду надо выполнить чертёжнику,...
grigoryanoksan
09.02.2023 00:29
Пользователь вводит четырехзначное число .проверить является ли оно числом палиндромом. 1441,5555 7117...
Чиангл
17.09.2021 07:33
Информационный объём текста, подготовленного с компьютера, равен 23 мб. 1 символ весит 1 байт. сколько символов содержит этот текст?...
СашаСтоляров1
20.07.2022 09:05
Решите 3 и объяните что обозначают z и x во втором и как их решить...
mamarozovap0c9td
12.12.2021 14:00
На складе лежали ящики с фруктами, сначалf со склада увезли 40% ящиков, а затем 20% остатка, после этого на складе осталось 10 ящиков.сколько ящиков было на складе первоначально?...
МарянДансер
12.12.2021 14:00
1.расставьте слова в предложения foreign, miss, start, took, uniform do you ……… your school friends in summer? we learn two ……… languages: english and french. denis …….. a lot...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
procedure Pl(var a,b,c,s:real);
var p:real;
begin;
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(s);
end;
begin;
readln(a);
readln(b);
readln(c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then
begin;
writeln('error');
exit;
end;
Pl(a,b,c,s);
end.
function f(a1,b1,c1:real):real;
var p:real;
begin
p:=(a+b+c)/2;
f:=sqrt(p*(p-a)*(p-b)*(b-c)); end;
BEGIN
readln(a,b,c);
writeln('S=',f(a,b,c):4:2);
end.