В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Arinka26052005
Arinka26052005
18.07.2020 20:49 •  Информатика

Напишите программу анализа значений больного за сутки определите максимальное и минимальное значения, среднее арифметическое замеры температуры проводят шесть раз в сутки и результаты вводятся с клавиатуры в массив т

Ответ:
Топирчик
Топирчик
03.10.2020 01:12
Вот TURBO PASCAL
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 uses crt; var i,sum,tmax,tmin:integer;sred:real; t:array [1..30] of integer; begin clrscr; sum:=0; writeln('vvedite T -> '); for i:=1 to 6 do begin write(i,' zamer t = '); read(t[i]); end; tmax:=t[1]; tmin:=t[1]; for i:=2 to 6 do begin if t[i]>tmax then tmax:=t[i]; if t[i]<tmin then tmin:=t[i]; end; for i:=1 to 6 do sum:=sum+t[i]; sred:=sum/6; writeln('Max T = ',tmax); writeln('Min T = ',tmin); writeln('srednyaya T = ',sred:3:3); readkey; end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?