В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lime89cc
lime89cc
04.02.2021 04:27 •  Информатика

1.с клавиатуры вводят слово и симвал.составьте программу ,которая а)проверяет,есть ли в этом слове данный симвал. б)определяет позицию данного символа. в)подсчитывает количество входов данного символа. 2.с клавиатуры вводят
ряд и слово.составьте программу ,которая а)определяет позицию данного слова. сделайте что сможете !

Ответ:

 Вот первая программа. Вторую сейчас пишу.

program p_1;
var
a,b:string;
i,k:integer;
begin
k:=0;
write('Введите слово ');
readln(a);
write('Введите символ ');
readln(b);
for i:=1 to length(a) do
begin
if a[i]=b then k:=k+1;
if a[i]=b then writeln(i,' ');
end;
if k>=1 then
writeln('Да, встречается ',k,' раз, на позиции указанных сверху в столбик ')else writeln('Нет');
end.

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?