В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qhahz
qhahz
09.05.2021 18:56 •  Информатика

Нужно составить программу с repeat,определяющую максимальное из всех введённых вами чисел.(пусть признаком конца ввода чисел является введённое число 0).

Ответ:
EvilQueen25
EvilQueen25
26.05.2020 23:20

var
i, e : Integer;
begin

Writeln('Вводите числа:');

i := 0;

repeat
Readln(e);

if e > i then i := e;
until e = 0;

Writeln('Наибольшее число: ', i);

end.

0,0(0 оценок)
Ответ:
NeZoX11111111
NeZoX11111111
26.05.2020 23:20

Program abc;

uses crt;

const n=30;

var

a:array[1..n] of integer;

i, max:integer;

begin

clrscr; 

for i:=1 to n do

read(a[i]);

max:=a[1];

for i:=2ton do

if a[i]>max then max:=a[i];

write('max=',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?