Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
34Настюша1111
27.12.2022 06:49 •
Информатика
надо составить программу. 1)у наибольшего из чисел x,y,z найти цифру младшего разряда(единиц) и остаток от его деления на 3. 2)написать программу,которая по номеру дня недели выдаёт количество уроков на следующий день.
Ответ:
majten
17.09.2020 13:56
2. var n: Integer;
Begin
readln(n);
write('Уроков ');
case n of
1: writeln('6');
2: writeln('6');
3: writeln('6');
4: writeln('5');
5: writeln('5');
6: writeln('нет');
7: writeln('6');
end;
End.
0,0
(0 оценок)
Ответ:
Ирочка300
17.09.2020 13:56
Согласно первому заданию надо сначала найти максимальный элемент
uses crt;
var x,y,z,max:integer;
Begin
writeln('Введите x y z');
readln(x,y,z);
if (x>y) and (x>z)
then max:=x
else
if (y>x) and (y>z)
then max:=y
else max:=z;
Writeln('max =',max);
Writeln('Младший разряд =',max mod 10);
Writeln('Остаток от деления на 3 =',(max mod 10) mod 3);
readln;
end.
2)
var n: Integer;
Begin
writeln('Введите день недели');
readln(n);
write('Уроков ');
case n of
1-4: writeln('6');
5,6: writeln('5');
7: writeln('нет');
end;
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
5polinka
10.02.2020 13:31
Решите письменно на листочке Переведите число 1251 из десятичной в ДВОИЧНУЮ2) Переведите число 196 из десятичной в ДВОИЧНУЮ3) Переведите число 1011 из ДВОИЧНОЙ в десятичную4)...
aggrib
11.09.2020 22:29
1.графический объект в текстовом документе? 2.число экземпляров документа? 3.единица измерения высоты шрифта? 4.знак, входящий в алфавит? 5.часть текста?...
witerold
25.11.2020 06:21
Сколько бит памяти достаточно для кодирования одного пикселя 16-цветного изображения...
sasha60503
25.11.2020 06:21
111. даны полные имена файлов, хранящихся на диске d: d: \млекопитающие\ластоногие\тюлени.txt d: \млекопитающие\ластоногие\моржи .txt d: \млекопитающие\хищники\медвеи\панды. txt...
Maria150305
25.06.2020 08:00
Это надо сделать в пайтане...
klemeshova1989
01.01.2022 22:43
У исполнителя Калькулятор две команды : 1. прибавь 2 2. умножь на 2 Какие результаты получит Калькулятор , выполнив программу 122112 для заданных чисел ? Запишите полные цепочки...
hermandad
29.12.2021 23:28
Речення з літератури та синтаксичний розбір...
nikitakuryan228
29.12.2021 23:28
Первую часть пути поезд проехал за 5 ч. с некотрой постоянной скоростью, а вторую часть за 3 часа со скоростью на 10 км/ч больше. какова его скорость на каждой части пути, если...
ChocolateMilk1
29.12.2021 23:28
Сделайте полный синтаксический разбор сложносочиненного предложения (по схеме): солнце уже заходило, и его лучи проникали сквозь рощу, светились на стволах....
nightmarelucy
29.12.2021 23:28
1- выражение: (3a-b)^2-(a^2+2b^2). 2- разложите на множители многочлен: 3х^2у-3уz^2. 3- катер плыл 2ч по течению реки, а затем 1ч по озеру и всего проплыл 54 км. какова собственная...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Begin
readln(n);
write('Уроков ');
case n of
1: writeln('6');
2: writeln('6');
3: writeln('6');
4: writeln('5');
5: writeln('5');
6: writeln('нет');
7: writeln('6');
end;
End.
uses crt;
var x,y,z,max:integer;
Begin
writeln('Введите x y z');
readln(x,y,z);
if (x>y) and (x>z)
then max:=x
else
if (y>x) and (y>z)
then max:=y
else max:=z;
Writeln('max =',max);
Writeln('Младший разряд =',max mod 10);
Writeln('Остаток от деления на 3 =',(max mod 10) mod 3);
readln;
end.
2)
var n: Integer;
Begin
writeln('Введите день недели');
readln(n);
write('Уроков ');
case n of
1-4: writeln('6');
5,6: writeln('5');
7: writeln('нет');
end;
End.