В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
DrSteklis
DrSteklis
24.11.2021 00:48 •  Информатика

Напишите программу для abc pascal для вывода n числа фибоначчи, где n < =40. массив не использовать

Ответ:
Мел228
Мел228
13.08.2020 14:21
Var    a,b,c,i,n: integer;
begin   
write('n = ');   
readln(n);    
a := 0;   
write(a,' ');    b := 1;    write(b,' ');   
 for i:=3 to n do begin     
  write(a+b,' ');       
 c := b;       
b := a + b;       
a := c   
 end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?