В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Фикус04
Фикус04
12.08.2020 20:39 •  Информатика

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет отрицательные на -1

Ответ:
Дима99999910
Дима99999910
07.08.2020 19:25
Var a:array[1..7] of integer; i:integer; n1:real;
begin
writeln('Введите 7 целых чисел');
for i:=1 to 7 do
begin
repeat
read(n1);
if (n1<>round(n1)) then  writeln('Необходимо целое число');
until (n1=round(n1));
a[i]:=round(n1);
end;
for i:=1 to 7 do
begin
if a[i]<0 then a[i]:=-1;
end;
writeln('Полученный массив:');
for i:=1 to 7 do
write(a[i]:5);
writeln('');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?