В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kaka932
kaka932
05.07.2020 18:16 •  Информатика

Составить программу для вычесления площади и периметра треугольника(известны все три стороны) при двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. в паскале нужна программа

Ответ:
kairat0101
kairat0101
15.09.2020 12:25
Program zadanie;
var a, b, c, s, p, pp:real;
begin
writeln('Введите сторону a');
read(a);
writeln('Введите сторону b');
read(b);
writeln('Введите сторону c');
read(c);
p:=a+b+c;
pp:=p/2;
if (sqr(a)=sqr(b)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой a');
s:=1/2*b*c;
writeln('Площадь = ',s);
end;
if (sqr(b)=sqr(a)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой b');
s:=1/2*a*c;
writeln('Площадь = ',s);
end;
if (sqr(c)=sqr(b)+sqr(a))  then
begin
writeln('Прямоугольный треугольник с гипотенузой c');
s:=1/2*b*a;
writeln('Площадь = ',s);
end
else
begin
writeln('Непрямоугольный треугольник');
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
writeln('Площадь = ',s);
end;
writeln('Периметр = ',p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?