В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SuperRhino757
SuperRhino757
08.01.2020 18:59 •  Информатика

Ниже написана программа. получив на вход число x, эта программа печатает два числа, a и b. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9. с решением! var x, a, b : integer; begin readln (x); a : = 0; b : = 1; while x > 0 do begin a : = a + 1; b : = b * (x mod 5); x : = x div 5; end; writeln (a); write (b); end.

Ответ:
andrekonushew
andrekonushew
02.10.2020 23:35
//Я снова предстаю в ипостаси гуманитария, не желающего ничего считать
//Сделаем так, чтобы код сам выдавал нам ответы
var x,a,b,m:integer;
begin
for m:=1 to 10000 do //m- тот же x, сохранённый для цикла
begin;
x:=m;
a := 0;
b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 5);
x := x div 5;
end;
if (a=3) and (b=9) then writeln(m);
//если программа должна вернуть подходящие нам значения, возвращаем x
end;
end.

Вывод программы:
43
83
91

ответ:91
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?