В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kalmuratov70
kalmuratov70
10.02.2023 10:20 •  Информатика

Составить программу, которая формирует массив из 5 случайных чисел от -10 до 15. а) найти элементы равные 1. б) найти индекс нечетных элементов. в) найти количество положительных элементов.

Ответ:
Masha6655
Masha6655
06.08.2020 21:52
Const n=5;
var a : array[1..n] of integer;
     k,i : integer;
begin
Randomize;
 for i:=1 to n do
 begin
  a[i]:=random(26)-10;
  write(a[i],' ');
 end;
writeln;
 writeln('элементы равные 1 имеют номера:');
for i:=1 to n do if a[i]=1 then write(i:3);
writeln;
writeln('индексы нечетных элементов:');
for i:=1 to n do if a[i] mod 2<>0 then write(i:3);
writeln;
k:=0;
for i:=1 to n do if a[i]>0 then k:=k+1;
writeln('количество положительных элементов=',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?