В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olegmelkov
olegmelkov
25.08.2022 01:11 •  Информатика

Написать программу на паскале дан массив.вставить число к перед и после элементов,которые заканчиваются на ту же цифру,что и к

Ответ:
zuevbogdan2017
zuevbogdan2017
13.08.2020 14:07
Const n=10;
type mas=array[1..3*n] of integer;
 procedure ins(var a:mas;k,nom:integer);
var i:integer;
begin
 for i:=3*n downto nom+3 do a[i]:=a[i-2];
 a[nom+1]:=a[nom]; a[nom]:=k; a[nom+2]:=k;
end;
var b : mas; k,i,j : integer;
begin
Randomize;
 for i:=1 to n do begin
   b[i]:=random(51);
   write(b[i]:4);
 end;
writeln;
write('K=');readln(k);
j:=1;
for i:=1 to n do
  if (b[j] mod 10 = k mod 10) then
    begin   ins(b,k,j); j:=j+3   end
  else j:=j+1;
for i:=1 to 3*n do write(b[i]:4);
  writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?