В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
yulyaahunova1
yulyaahunova1
08.06.2023 00:33 •  Информатика

Составьте программу вывода на экран n первых чисел фибонаги (это числовая последовательность 1,1,2,3,5,8, вычисляются по правилу: а1=1,а2=1,а3=а2+=аn-1+an-2(после -а- это ! )pascal abc

Ответ:
kizaru28
kizaru28
16.09.2020 23:29
Var i,n:integer; a,b:int64; begin read(n); a:=1; b:=1; if (n=1) then write(a) else if (n>=2) then write(a,', ',b); if (n>2) then for i:=1 to n-2 do begin b:=b+a; a:=b-a; write(', ',b); end; End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?