В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Юра754
Юра754
22.08.2020 05:50 •  Информатика

Составить программу на паскале дано натуральное число,найти сумму цифр этого числа!

Ответ:
nikaknekto
nikaknekto
26.05.2020 18:17

Program Program1;
var
i,sum,n,code:integer;
s:string;
begin
write('Введите натуральноее число: ');
readln(s);

sum:=0;
for i := 1 to Length(s) do
begin
Val(s[i], n, code);
sum:=sum + n;
end;
writeln('Сумма цифр: ', sum)
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?