Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
мама1035
17.05.2020 12:45 •
Информатика
Составить программу "вычисление площади прямоугольника ,если заданы координаты 3-х его вершин"
Ответ:
asti2000
25.08.2020 01:51
Var x1,y1,z1,x2,y2,z2,x3,y3,z3,abx,aby,abz,acx,acy,acz,s,mx,my,mz,c:real;
begin;
readln(x1);
readln(y1);
readln(z1);
readln(x2);
readln(y2);
readln(z2);
readln(x3);
readln(y3);
readln(z3);
abx:=x2-x1;
acx:=x3-x1;
aby:=y2-y1;
acy:=y3-y1;
abz:=z2-z1;
acz:=z3-z1;
mx:=aby*acz-abz*acy;
my:=abz*acx-abx*acz;
mz:=abx*acy-aby*acx;
c:=sqrt(sqr(mx)+sqr(my)+sqr(mz));
s:=0.5*c;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
morfikk
04.06.2020 22:15
Вгирлянде 25 лампочек, каждая может гореть или не гореть. какое наибольшее возможное количество различных состояний может быть у гирлянды, если в ней не могут быть выключенными...
дима0951871812
23.02.2023 19:22
Объем оперативной памяти 0,5 кбайт сколько ячеек...
linakkj
28.07.2022 09:02
Проблема в microsoft access - , подскажите возможное решение! вместо цифр выдает знак # - в мастере запросов задала функцию sum для , , причину проблемы и возможности...
1FACE1
13.02.2020 05:14
Кол-во нулей в двоичной записи числа 132? 1153(8)=? (16) de7b(16)=? (8) надо к завтрашнему дню! : (...
sasha228111228
06.01.2023 10:34
Какое максимальное десятичное число может располагаться в четырех восьмерном разряде? А) 2400 В) 2401 C) 4095 D) 7777 E) 9999...
ilhammusayev965
28.06.2020 19:22
1.Правосудием является: 1) рассмотрение и разрешение судами конкретных дел; 2) рассмотрение и разрешение спорных правовых вопросов комиссией по трудовым спорам; З) рассмотрение...
polyhovichvikto
12.02.2020 14:03
Відомо, що трикутники АВС і МКР подібні. Знайдіть градусну міру кута С, якщо градусні міри кутів А і К дорівнюють відповідно 30 і 70 градусів. *...
costa174rus
10.11.2021 00:27
прямокутну смужку паперу розмірами 4 смх13 см перегинають. Два утворені прямокутники мають площі P і Q, де Р = 2Q,. Чому дорівнює значення х?...
bezimeni3
01.05.2020 07:33
На сторонах кута B,що дорівнює 120°, відкладено відрізки BA=BC=4см. Проведіть коло через точки A,B,C і знайдіть його радіус...
YaKuss
16.01.2023 19:52
Узнай , будут прямые 4 x + 5 y- 7 = 0 и 8 x - 3 y- 1 = 0 пересекаться в точке \ (A ( 0,5 ; 1 ) \)? ответ:прямые 4 x + 5 y- 7 = 0 и 8 x - 3 y- 1 = 0 в точкеA ( 0,5 ; 1...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin;
readln(x1);
readln(y1);
readln(z1);
readln(x2);
readln(y2);
readln(z2);
readln(x3);
readln(y3);
readln(z3);
abx:=x2-x1;
acx:=x3-x1;
aby:=y2-y1;
acy:=y3-y1;
abz:=z2-z1;
acz:=z3-z1;
mx:=aby*acz-abz*acy;
my:=abz*acx-abx*acz;
mz:=abx*acy-aby*acx;
c:=sqrt(sqr(mx)+sqr(my)+sqr(mz));
s:=0.5*c;
writeln(s);
end.