В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Alvn
Alvn
24.09.2020 09:53 •  Информатика

Нужна ваша ! написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( в ответе достаточно рабочего кода)

Ответ:
astafievaolga20
astafievaolga20
16.09.2020 22:14
Const n=5; m=6;
var a: array [1..n,1..m] of integer;
    sum,min,i,j:integer;
begin
Randomize;
writeln('---A:---');
for i:=1 to n do begin
  for j:=1 to m do begin
    a[i,j]:=Random(20)-10;
    write(a[i,j]:6);
  end;
  writeln;
end;
writeln('Среднее арифм. столбцов:');
min:=100000;
for j:=1 to m do begin
 sum:=0;
 for i:=1 to n do sum:=sum+a[i,j];
 write(sum/n:6:2);
 if sum<min then min:=sum;
end;
writeln;
writeln('Min=',min/n:6:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?