В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Perchyn0601
Perchyn0601
28.12.2022 21:01 •  Информатика

Написать программу в паскале с оператора выбора(case.. of.. else) : напишите программу для вычисления степени введённого с клавиатуры числа. степень в диапазоне 0 .. 9. p.s: я начинающий в программировании, поэтому попонятней написать.

Ответ:

var a,b,c:integer;
begin
writeln('введите число и степень'); {здесь прост программа тебя спрашивает какие числа}
read(a,b);    {здесь программа читает их}
case b of       {тут выполняется условие типа если b и идут сами степени}
0: writeln(1);
1: writeln(a);   {здесь что программа выдаст если ты напишешь такую степень}
2: writeln (a*a);
3: writeln (a*a*a);
4: writeln (a*a*a*a);
5: writeln (a*a*a*a*a);
6: writeln (a*a*a*a*a*a);
7: writeln (a*a*a*a*a*a*a);
8: writeln (a*a*a*a*a*a*a*a);
9: writeln (a*a*a*a*a*a*a*a*a);
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?