В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vanek255
Vanek255
22.05.2022 13:45 •  Информатика

Составить программу, которая: a) определяет два символа по их , введенных с клавиатуры; b) вывести их на экран в порядке убывания.

Ответ:
mlk000100
mlk000100
31.07.2020 09:27
// PascalABC.Net 3.0, сборка 1064
var
  a,b:byte;
begin
  Write('Введите два кода символов, большие 31: '); Read(a,b);
  if (a<32) or (b<32) then Writeln('Код должен быть больше 31')
  else begin
    Write('Символы, соответствующие кодам: <');
    if a>b then Write(Chr(a),'> и <',Chr(b),'>')
    else Write(Chr(b),'> и <',Chr(a),'>')
  end
end.

Тестовое решение:
Введите два кода символов, большие 31: 42 198
Символы, соответствующие кодам: <Ж> и <*>
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?