В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
danilka107
danilka107
09.06.2020 09:26 •  Информатика

:составьте программу ввода с клавиатуры элементов массива a[1..10] и вывода на экран элементов, значения которых являются квадратами целых чисел. вот что я составил, но извлечение корня нельзя делать в integer: ( ! program shist; var a: array [1..10] of integer; i: integer; begin writeln('введите элементы массива: '); readln(i); writeln('элементы массива, значения которых являются квадратами целых чисел: '); for i: =1 to 10 do if sqrt(i) then write (a[i], ' ') end.

Ответ:
Dedula5
Dedula5
02.10.2020 22:53
Текст программы на языке Паскаль:

program _1;
const N=10;
var i: integer; 
a: array[1..N] of integer;
begin
for i:=1 to N do begin
readln(a[i]);
a[i]:=a[i]*a[i];
end;
for i:=1 to N do begin
writeln(a[i]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?