В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bvoznyk69
bvoznyk69
18.09.2022 04:46 •  Информатика

Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3,а к нечётное умножает на 4

Ответ:
Софайа
Софайа
26.05.2020 17:25

Program Program1;
var
i:integer;
a:array [1..10] of integer;
begin
randomize;
writeln;
writeln('Массив до преобразования:');
for i:=1 to 10 do
begin
a[i]:=random(8);
write(a[i],', ');
end;
for i:=1 to 10 do
if a[i] mod 2 = 0 then
a[i]:=a[i]+3
else
a[i]:=a[i]*4;
writeln;
writeln('Массив после преобразования:');
for i:=1 to 10 do
write(a[i],', ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?