В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
newyorker2000
newyorker2000
23.03.2021 17:56 •  Информатика

Программа с++ задан числовой массив а[1: m, 1: n]. составить программу поиска элемента массива, который является одновременно наименьшим в строке и наибольшим в своем столбце. вывести номер столбца и строки, если такой элемент есть и 0 если нет.

Ответ:
blackmaster2442
blackmaster2442
07.06.2020 04:02

#include <iostream>

#include <cstdlib>

using namespace std;

int main(){

   int a[n][m];

   int minA[m];

   int min;

   for(int i = 0; i < n; i++){

       for(int j = 0; j < m; j++){

           a[i][j] = rand()% 50 - 10;

           cout<<a[i][j]<<" ";

       }

   cout<<endl;

   }

   cout <<"Min:"<<endl;

   for(int j = 0; j < m; j++){

       min = 9999;

       for(int i = 0; i < n; i++){

           if((a[i][j] > 0) && (a[i][j] < min))

               min = a[i][j];

       }

       minA[j] = min;

       cout<<minA[j]<<" ";

   }

   int max = minA[0];

       for(int j = 1; j < m; j++){

           if(max < minA[j])

               max = minA[j];

       }

   cout<<endl<<"Max = "<<max;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?