В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aarianna
aarianna
12.05.2023 14:32 •  Информатика

Дан массив из 5 элементов, составить программу, которая возводит в квадрат элементы, которые как кратные 4, так и положительны

Ответ:
Andreytsoy1
Andreytsoy1
19.08.2020 06:51
Var a:array [1..5] of integer;
begin
for i:=1 to 5 do
begin
read(a[i]);
if (a[i]>0) and (a[i] mod 4=0) then a[i]:=sqr(a[i]);
end;
for i:=1 to 5 do
write(a[i],' ')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?