В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу которая осуществляет ввод в массив с клавиатуры 10 элементов и отрицательные числа возводят в квадрат, а из неотрицательных извлекают квадратный корень

Ответ:
makaroshkaplay
makaroshkaplay
16.09.2020 14:24
Var a:array[1..10] of real;
i:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if a[i]<0 then a[i]:=sqr(a[i])
else a[i]:=sqrt(a[i]);
end;
for i:=1 to 10 do
write(a[i],' ')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?