В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tayna73p00m0k
tayna73p00m0k
12.10.2021 12:25 •  Информатика

Написать программу на языке с++ : в одной старинной мудрец предложил шаху в качестве награды за услугу выдать зерно. причем количество зерна оговорил так: на первую клетку шахматной доски положить 1 зерно, на 2-ую - 2, на 3-ю - 4, на 4-ую - 8 и т.д. составить программу, с которой можно вычислить, на какой клетке суммарное количество зерен превысит n штук.

Ответ:
misterion10
misterion10
31.07.2020 01:53
//
//   Разработал GonanSoft
//
int i; 
unsigned long long k=0; // сумма зёрен на i-ом шаге
unsigned long long s=1; // количество зерен в i-ой клетке 
unsigned long long n; // переменная признак окончания

cout << 'количество зерен '; 
cin>>n;
for (i = 1; i <= 64; i++) 
{
  k=k+s;
  if (n<k)
    break;
  s=s<<1; 
}

if (n<>18446744073709551615)  //это проверка на максимум зёрен
  cout << 'Номер клетки = ' << i << '\n';
else
  cout << 'Сумма зёрен не превысит 18446744073709551615  ' << i << '\n';
//
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?