В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MashaE631
MashaE631
19.02.2022 19:24 •  Информатика

Решить по информатике. нужно составить программу на паскале. найти среднее значение элементов двумерного массива и подсчитать, сколько в этом массиве элементов, превышающих среднее значение.

Ответ:
Youseee
Youseee
02.10.2020 22:27
USES CRT;
VAR A:array[1..3,1..3] of integer;   
        i,j,s,summa:integer;   
        sred:real;
BEGIN 
CLRSCR;
Randomize;

   summa:=0; 
   s:=0;
{Заполняем массив случайными числами от 0 до 15 и выводим на экран}
   For i:=1 to 3 do   
      begin   
         For j:=1 to 3 do     
            begin       
               A[i,j]:=Random(15);       
               Write(' ',A[i,j]:2,'  ');     
            end;    
         Writeln;   
      end;

{находим общую сумму всех элементов массива }
   For i:=1 to 3 do   
      For j:=1 to 3 do     
         begin       
            summa:=summa+A[i,j];       
            s:=s+1;     
         end;

   Writeln;
   Writeln(' ',summa,'   ',s);
   Writeln;
 
{Находим средне арифметическое число массива}
   sred:=summa/s;
   Writeln(' ',Средне арифметическое = ',sred:2:1);

   s:=0;

{считаем количество элементов превышающих среднее значение}
   For i:=1 to 3 do   
      For j:=1 to 3 do     
         if sred<A[i,j] then s:=s+1;

   Writeln;
   Writeln(' ',s,' элементов массива превышающие средне арифметическое');
READLN;
END.
Решить по информатике. нужно составить программу на паскале. найти среднее значение элементов двумер
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?