В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ryzhij
ryzhij
14.10.2022 15:46 •  Информатика

Написать программу на паскале, (максимально просто)дан массив из 15 элементов, отсортировать по возрастанию элементы массива являющиеся простыми числами.

Ответ:
miha115
miha115
25.03.2019 00:20

program pr10;

uses crt;

var

  i: integer;

  t: real; // рабочая переменная

  i: byte; // счетчик массива

  k: byte; // параметр цикла

  a: array[1..15] of real;

  n: byte; // размерность цикла

begin

  clrscr;

  write('введите размерность: ');

  readln(n);

  writeln('введите ',n,' элементов');

  for i: =1 to n do

      readln(a[i]);

      writeln('исходный массив: ');

  for i: =1 to n do

      write(a[i]: 5: 1,' ');

      readln;

// блок обработки

  for k: =1 to n do

      for i: =1 to n-k do

        if(a[i]> a[i+1]) then

// перестановка

            begin

              t: =a[i];

              a[i]: =a[i+1];

              a[i+1]: =t;

            end;

  writeln('отсортированный массив: ');

  for i: =1 to n do

      write(a[i],' ');

      writeln;

      readln;

end.

я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?