В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
IslamKapkaev
IslamKapkaev
17.07.2020 12:49 •  Информатика

Pascal abc. написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Ответ:
Albina1967
Albina1967
02.10.2020 22:22
Var
  a:array of integer;
  i,b,c:integer;

BEGIN
  write('Введите размер массива - ');
  readln(b);
  setlength(a,b);
  writeln('Введите элементы массива - ');
  for i:=0 to b-1 do begin
    readln(a[i]);
    if a[i] mod 2 = 0 then c:=c+a[i];
  end;
  writeln('Сумма четных элементов массива  - ',c);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?